赞助商广告,谨慎操作

通达信均线加涨停主图指标公式

[复制链接]
查看42 | 回复0 | 2021-1-12 10:00:17 | 显示全部楼层 |阅读模式
公众号

</div>
M5:=5;
M10:=10;
M21:=21;
M250:=250;
DRAWTEXT_FIX(1,0.00,0.00,0,'所属地域:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.00,0,DYBLOCK)COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.07,0,'所属行业:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.07,0,HYBLOCK)COLORFF00FF;
DRAWTEXT_FIX(1,0.00,0.15,0,'所属概念:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.15,0,GNBLOCK)COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.22,0,'所属风格:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.22,0,FGBLOCK)COLORFF00FF;
MA5天:&quot;MA.MA1#DAY&quot;(5,10,20),LINETHICK2,COLORRED;
STICKLINE(L&gt;REF(H,1),L,REF(H,1),7,1),COLORA8A8A8;
STICKLINE(H&lt;REF(L,1),H,REF(L,1),7,1),COLORA8A8A8;
{判断是否为创业或科创版}
RQ:=DATE+19000000;
创业注册:=INBLOCK('创业板') AND RQ&gt;=20200824;
PD:=创业注册 OR INBLOCK('科创板') ;
DRAWTEXT(IF(PD,0,1) AND H&gt;=REF(C,1)*1.098 AND C&lt;REF(C,1)*1.098,REF(C,1)*1.098,'曾');
DRAWTEXT(IF(PD,0,1) AND L&lt;=REF(C,1)*0.90,REF(C,1)*0.9,'曾跌');
DRAWTEXT(PD=1 AND H&gt;=REF(C,1)*1.198 AND C&lt;REF(C,1)*1.198,REF(C,1)*1.198,'曾');
DRAWTEXT(PD=1 AND L&lt;=REF(C,1)*0.805,REF(C,1)*0.805,'曾跌');
STICKLINE(IF(PD=1,0,1) AND C&gt;=REF(C,1)*1.097 AND C=H,O,C,1,0),COLORYELLOW;
STICKLINE(PD=1 AND C&gt;=REF(C,1)*1.197 AND C=H,O,C,1,0),COLORYELLOW;
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20),LINETHICK2;
MA250:MA(CLOSE,250),LINETHICK3,COLORRED;
MA60:MA(CLOSE,60);
{MA120:MA(CLOSE,M6);
MA250:MA(CLOSE,M7);
MA8:MA(CLOSE,M8);
MA9:MA(CLOSE,M9);}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MACD金叉:=BARSLAST(CROSS(DIFF,DEA)),NODRAW;
MACD死叉:=BARSLAST(CROSS(DEA,DIFF)),NODRAW;
FINANCE(42),NODRAW;
大于0:=DEA&gt;0 AND DIFF&gt;0 AND MACD&gt;0 AND REF(DEA,MACD金叉+1);
子母刀:=大于0 AND MACD死叉&gt;MACD金叉 AND REF(CLOSE,1)&gt;=ZTPRICE(REF(CLOSE,2),0.1) AND LOW&gt;(REF(HIGH,1)+0.001) AND MACD&gt;0 AND CLOSE&lt;HIGH;
{DRAWNUMBER(子母刀 AND C&lt;H,C,100*(H-C)/C),COLORYELLOW;}
DRAWTEXT(子母刀,REF(L,1),'子母连环刀'),LINETHICK9,COLORMAGENTA;
倚天剑:=HHV(H,FINANCE(42))&lt;=C AND BARSCOUNT(C)&gt;500 AND C&gt;=REF(C,1)*1.098 {AND REF(C,1)&lt;REF(C,2)*1.098}AND WEEKDAY=1;
DRAWTEXT(倚天剑,REF(L,1),'倚天剑'),LINETHICK9,COLORYELLOW;
A1:=C&gt;=REF(C,4);
A2:=C&lt;REF(C,4);
A3:=C&lt;REF(C,4) AND REF(A1,1);
T:=BARSLAST(A3),NODRAW;
M0:=(T=0 AND REFX(T=1 AND NOT(A2),1)) OR (REFX(T=2 AND NOT(A2),2)) OR (REFX(T=3 AND NOT(A2),3)) OR (REFX(T=4 AND NOT(A2),4)) OR (REFX(T=5 AND NOT(A2),5)) OR (REFX(T=6 AND NOT(A2),6)) OR (REFX(T=7 AND NOT(A2),7)) OR (REFX(T=8 AND NOT(A2),8));
M1:=T=1 AND REFX(T=2 AND NOT(A2),1) OR (REFX(T=3 AND NOT(A2),2)) OR (REFX(T=4 AND NOT(A2),3)) OR (REFX(T=5 AND NOT(A2),4)) OR (REFX(T=6 AND NOT(A2),5)) OR (REFX(T=7 AND NOT(A2),6)) OR (REFX(T=8 AND NOT(A2),7));
M2:=T=2 AND REFX(T=3 AND NOT(A2),1) OR (REFX(T=4 AND NOT(A2),2)) OR (REFX(T=5 AND NOT(A2),3)) OR (REFX(T=6 AND NOT(A2),4)) OR (REFX(T=7 AND NOT(A2),5)) OR (REFX(T=8 AND NOT(A2),6));
M3:=T=3 AND REFX(T=4 AND NOT(A2),1)OR (REFX(T=5 AND NOT(A2),2)) OR (REFX(T=6 AND NOT(A2),3)) OR (REFX(T=7 AND NOT(A2),4))  OR (REFX(T=8 AND NOT(A2),5));
M4:=T=4 AND REFX(T=5 AND NOT(A2),1) OR (REFX(T=6 AND NOT(A2),2)) OR (REFX(T=7 AND NOT(A2),3)) OR (REFX(T=8 AND NOT(A2),4));
M5:=T=5 AND  REFX(T=6 AND NOT(A2),1) OR (REFX(T=7 AND NOT(A2),2)) OR (REFX(T=8 AND NOT(A2),3));
M6:=T=6  AND  REFX(T=7 AND NOT(A2),1) OR (REFX(T=8 AND NOT(A2),2));
M7:=T=7  AND  REFX(T=8 AND NOT(A2),1);
N0:=T=1 AND REF(T=0 AND A3,1) AND A2;
N1:=T=2 AND REF(N0,1) AND A2;
N2:=T=3 AND REF(N1,1) AND A2;
N3:=T=4 AND REF(N2,1) AND A2;
N4:=T=5 AND REF(N3,1) AND A2;
N5:=T=6 AND REF(N4,1) AND A2;
N6:=T=7 AND REF(N5,1) AND A2;
N7:=T=8 AND REF(N6,1) AND A2;
WZD:=L*0.985;
WZG:=H*1.011;
DRAWTEXT(N6 AND NOT(M7),WZD,'8'),COLORGREEN;
DRAWTEXT(N7,H,'9'),LINETHICK9,COLORMAGENTA;
B1:=C&lt;=REF(C,4);
B2:=C&gt;REF(C,4);
B3:=C&gt;REF(C,4) AND REF(B1,1);
T1:=BARSLAST(B3),NODRAW;
M8:=(T1=0 AND REFX(T1=1 AND NOT(B2),1)) OR (REFX(T1=2 AND NOT(B2),2)) OR (REFX(T1=3 AND NOT(B2),3)) OR (REFX(T1=4 AND NOT(B2),4)) OR (REFX(T1=5 AND NOT(B2),5)) OR (REFX(T1=6 AND NOT(B2),6)) OR (REFX(T1=7 AND NOT(B2),7)) OR (REFX(T1=8 AND NOT(B2),8));
M9:=T1=1 AND REFX(T1=2 AND NOT(B2),1) OR (REFX(T1=3 AND NOT(B2),2)) OR (REFX(T1=4 AND NOT(B2),3)) OR (REFX(T1=5 AND NOT(B2),4)) OR (REFX(T1=6 AND NOT(B2),5)) OR (REFX(T1=7 AND NOT(B2),6)) OR (REFX(T1=8 AND NOT(B2),7));
M10:=T1=2 AND REFX(T1=3 AND NOT(B2),1) OR (REFX(T1=4 AND NOT(B2),2)) OR (REFX(T1=5 AND NOT(B2),3)) OR (REFX(T1=6 AND NOT(B2),4)) OR (REFX(T1=7 AND NOT(B2),5)) OR (REFX(T1=8 AND NOT(B2),6));
M11:=T1=3 AND REFX(T1=4 AND NOT(B2),1)OR (REFX(T1=5 AND NOT(B2),2)) OR (REFX(T1=6 AND NOT(B2),3)) OR (REFX(T1=7 AND NOT(B2),4))  OR (REFX(T1=8 AND NOT(B2),5));
M12:=T1=4 AND REFX(T1=5 AND NOT(B2),1) OR (REFX(T1=6 AND NOT(B2),2)) OR (REFX(T1=7 AND NOT(B2),7)) OR (REFX(T1=8 AND NOT(B2),4));
M13:=T1=5 AND  REFX(T1=6 AND NOT(B2),1) OR (REFX(T1=7 AND NOT(B2),2)) OR (REFX(T1=8 AND NOT(B2),3));
M14:=T1=6  AND  REFX(T1=7 AND NOT(B2),1) OR (REFX(T1=8 AND NOT(B2),2));
M15:=T1=7  AND  REFX(T1=8 AND NOT(B2),1);
N8:=T1=1 AND REF(T1=0 AND B3,1) AND B2;
N9:=T1=2 AND REF(N8,1) AND B2;
N10:=T1=3 AND REF(N9,1) AND B2;
N11:=T1=4 AND REF(N10,1) AND B2;
N12:=T1=5 AND REF(N11,1) AND B2;
N13:=T1=6 AND REF(N12,1) AND B2;
N14:=T1=7 AND REF(N13,1) AND B2;
N15:=T1=8 AND REF(N14,1) AND B2;
DRAWTEXT(N14 AND NOT(M15),WZG,'8'),COLOR9900CC;
DRAWTEXT(N15 ,L,'9'),LINETHICK3,COLORGREEN;



                       
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 马上注册

本版积分规则