赞助商广告,谨慎操作

通达信金钻起航牛股选股指标公式

[复制链接]
查看7 | 回复0 | 2020-11-21 10:00:19 | 显示全部楼层 |阅读模式
公众号

</div>
X_1:=IF(NAMELIKE(2),0,1);
X_2:=IF(NAMELIKE(3),0,1);
X_3:=DYNAINFO(4)&gt;0;
X_4:=FINANCE(7)&lt;=8000000000;
X_5:=CLOSE/REF(CLOSE,1)&gt;1.0975 AND HIGH=OPEN;
X_6:=X_1 AND X_2 AND X_3 AND X_4 AND NOT(X_5);
X_7:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
X_8:=(HIGH+LOW+CLOSE)/3;
X_9:=IF(CLOSE&gt;OPEN AND HIGH&gt;REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_10:=IF(CLOSE&gt;OPEN AND HIGH&lt;REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);
X_11:=IF(CLOSE&gt;OPEN AND HIGH=REF(CLOSE,1),0,0);
X_12:=IF(CLOSE&lt;OPEN AND HIGH&gt;REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_13:=IF(CLOSE&lt;OPEN AND HIGH&lt;REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);
X_14:=IF(CLOSE&lt;OPEN AND HIGH=REF(CLOSE,1),0,0);
X_15:=X_9+X_10+X_11+X_12+X_13+X_14;
X_16:=MA(X_15,9);
X_17:=MA(X_15,5);
X_18:=MA(X_15,3);
X_19:=ATAN((HIGH-REF(HIGH,1))/REF(HIGH,1)/0.1)/6.28*360;
X_20:=ATAN((LOW-REF(LOW,1))/REF(LOW,1)/0.1)/6.28*360;
X_21:=ATAN((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)/0.1)/6.28*360;
X_22:=ATAN((OPEN-REF(OPEN,1))/REF(OPEN,1)/0.1)/6.28*360;
X_23:=MIN(MIN(MIN(X_21,X_22),X_19),X_20);
X_24:=MAX(MAX(MAX(X_21,X_22),X_19),X_20);
X_25:=MIN(X_21,X_22);
X_26:=MAX(X_21,X_22);
X_27:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-X_8);
X_28:=IF(CLOSE&gt;OPEN AND LOW&gt;REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_29:=IF(CLOSE&gt;OPEN AND LOW&lt;REF(CLOSE,1),-(ATAN(REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);
X_30:=IF(CLOSE&gt;OPEN AND LOW=REF(CLOSE,1),0,0);
X_31:=IF(CLOSE&lt;OPEN AND LOW&gt;REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);
X_32:=IF(CLOSE&lt;OPEN AND LOW&lt;REF(CLOSE,1),-ATAN((REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);
X_33:=IF(CLOSE&lt;OPEN AND LOW=REF(CLOSE,1),0,0);
X_34:=X_28+X_29+X_30+X_31+X_32+X_33;
X_35:=MA(X_34,9);
X_36:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
X_37:=MA(X_34,5);
X_38:=MA(X_34,3);
X_39:=ATAN(X_16/0.09);
X_40:=ATAN(X_17/0.05);
X_41:=ATAN(X_18/0.03);
X_42:=ATAN((-X_35)/0.09);
X_43:=ATAN((-X_37)/0.05);
X_44:=ATAN((-X_38)/0.03);
X_45:=CLOSE/REF(CLOSE,1)&gt;1.028 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_46:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),15);
X_47:=IF(HIGH=LOW,1,X_8-MIN(CLOSE,OPEN));
X_48:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
X_49:=IF(X_26&gt;0 AND X_25&gt;0,X_26,0);
X_50:=IF(X_26&lt;0 AND X_25&lt;0,X_25,0);
X_51:=IF(X_26&gt;0 AND X_25&lt;0,X_26,0);
X_52:=IF(X_26&gt;0 AND X_25&lt;0,X_25,0);
X_53:=X_7*X_48;
X_54:=X_48*X_27;
X_55:=X_36*X_48;
X_56:=X_47*X_48;
X_57:=X_56+X_55;
X_58:=X_53+X_54;
X_59:=X_57-X_58;
X_60:=X_59;
X_61:=FILTER(X_45,28);
X_62:=(X_41+X_40+X_39)/3/6.28*360;
X_63:=X_62-REF(X_62,1)&gt;0;
X_64:=EMA(CLOSE,5);
X_65:=MA(X_49+X_51,1);
X_66:=MA(X_50+X_52,1);
X_67:=X_65+X_66;
X_68:=FINDHIGH(X_24,1,3,1);
X_69:=FINDHIGH(X_24,1,3,2);
X_70:=BARSCOUNT(X_68)&lt;BARSCOUNT(X_69);
X_71:=IF(X_70,X_68,0);
X_72:=IF(X_70,X_69,0);
X_73:=X_71-X_72;
X_74:=MA(REF(X_68+X_73,1),5);
X_75:=X_74-REF(X_74,1)&gt;0;
X_76:=(CLOSE-X_64)/X_64*100;
X_77:=ATAN((X_64/REF(X_64,1)-1)*100)*180/3.1416;
X_78:=EMA(CLOSE,30);
X_79:=HIGH-REF(HIGH,1);
X_80:=REF(LOW,1)-LOW;
X_81:=EXPMEMA(IF(X_79&gt;0 AND X_79&gt;X_80,X_79,0),15);
X_82:=X_81*100/X_46;
X_83:=X_82-REF(X_82,1)&gt;0;
X_84:=(CLOSE-X_78)/X_78*100;
X_85:=COUNT(CROSS(X_76,0),3)&gt;=1 AND X_84&gt;REF(X_84,1) AND X_64&gt;REF(X_64,1) AND (CLOSE/REF(CLOSE,1)-1)*100&gt;2 AND REF(CLOSE,1)&lt;X_78;
X_86:=FILTER(X_85,10);
X_87:=MA(X_59,5)*20;
X_88:=SMA(X_87,3,1);
X_89:=X_88-REF(X_88,1)&gt;0;
XG:X_61 AND X_63 AND X_62&gt;30 AND X_6 AND X_75 AND X_83 AND X_89,COLORRED;


                       
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 马上注册

本版积分规则