赞助商广告,谨慎操作

通达信江恩斐波主图指标公式

[复制链接]
查看8 | 回复0 | 2020-11-20 10:00:33 | 显示全部楼层 |阅读模式
公众号

</div>
HDAY:=20;
LDAY:=20;
上角度:=70;
下角度:=70;
调点:=3;
CURR:=CURRBARSCOUNT;
TCH:=CONST(FINDHIGH(H,0,HDAY*10,1));
GTT:=CONST(BARSLAST(TCH=H))+1;
SX跌H:=CONST(IF(GTT=1,H,REF(H,GTT-1)));
BCL:=CONST(FINDLOW(L,0,LDAY*10,1));
DTT:=CONST(BARSLAST(BCL=L))+1;
SX涨L:=CONST(IF(DTT=1,L,REF(L,DTT-1)));
涨点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(L=SX涨L)+1));
跌点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(H=SX跌H)+1));
最低:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,涨点,跌点)));
L斜率:=下角度/IF(C&lt;300,1000,10);
最高:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,跌点,涨点)));
H斜率:=上角度/IF(C&lt;300,1000,10);
IM68:=((SX跌H-SX涨L)/8-(SX跌H-SX涨L)/8);
GH跌X:=SX跌H+(SX跌H-SX涨L)/8;
DL涨X:=SX涨L-(SX跌H-SX涨L)/8;
GTHT:=IF(DTT&gt;GTT,DTT,GTT);
R:=ABS(GTT-DTT);
DHHRAWBAND(IF(CURR&lt;=GTHT,SX跌H,DRAWNULL),RGB(0,120,120),SX跌H,RGB(8,168,168));
DLLRAWBAND(IF(CURR&lt;=GTHT,SX涨L,DRAWNULL),RGB(0,120,120),SX涨L,RGB(0,160,160));
STICKLINE(CURRBARSCOUNT=GTT,SX跌H,SX涨L,0,0),COLOR556600;
STICKLINE(CURRBARSCOUNT=DTT,SX跌H,SX涨L,0,0),COLOR666666;
STICKLINE(CURRBARSCOUNT=1,SX跌H,SX涨L,0,0),COLOR556600;
天线:=SX跌H;
地线:=SX涨L;
K:=(天线-地线)/(IF(跌点&gt;=涨点,跌点,涨点)-IF(跌点&gt;=涨点,涨点,跌点));
上斜线:=IF(地线+CONST(L斜率*4.00)*最低&gt;=地线,地线+CONST(L斜率*4.00)*最低,DRAWNULL);
上斜线0:=IF(地线+CONST(L斜率*2.00)*最低&gt;=地线,地线+CONST(L斜率*2.00)*最低,DRAWNULL);
上斜线1:=IF(地线+CONST(L斜率*1.5)*最低&gt;=地线,地线+CONST(L斜率*1.5)*最低,DRAWNULL);
上斜线2:=IF(地线+CONST(L斜率*1.00)*最低&gt;=地线,地线+CONST(L斜率*1.000)*最低,DRAWNULL);
上斜线3:=IF(地线+CONST(L斜率*0.70)*最低&gt;=地线,地线+CONST(L斜率*0.70)*最低,DRAWNULL);
上斜线4:=IF(地线+CONST(L斜率*0.50)*最低&gt;=地线,地线+CONST(L斜率*0.50)*最低,DRAWNULL);
上斜线5:=IF(地线+CONST(L斜率*0.365)*最低&gt;=地线,地线+CONST(L斜率*0.365)*最低,DRAWNULL);
上斜线6:=IF(地线+CONST(L斜率*0.250)*最低&gt;=地线,地线+CONST(L斜率*0.250)*最低,DRAWNULL);
上斜线7:=IF(地线+CONST(L斜率*0.165)*最低&gt;=地线,地线+CONST(L斜率*0.165)*最低,DRAWNULL);
上斜线8:=IF(地线+CONST(L斜率*0.123)*最低&gt;=地线,地线+CONST(L斜率*0.123)*最低,DRAWNULL);
上斜线9:=IF(地线+CONST(L斜率*0.06)*最低&gt;=地线,地线+CONST(L斜率*0.06)*最低,DRAWNULL);
上9:IF(上斜线9&lt;=天线*1.05,上斜线9,DRAWNULL),COLORAA00AA,DOTLINE;
上8:IF(上斜线8&lt;=天线*1.05,上斜线8,DRAWNULL),COLORAA00AA,DOTLINE;
上7:IF(上斜线7&lt;=天线*1.05,上斜线7,DRAWNULL),COLORAA00AA,DOTLINE;
上6:IF(上斜线6&lt;=天线*1.05,上斜线6,DRAWNULL),COLORAA00AA,DOTLINE;
上5:IF(上斜线5&lt;=天线*1.05,上斜线5,DRAWNULL),COLORAA00AA,DOTLINE;
上4:IF(上斜线4&lt;=天线*1.05,上斜线4,DRAWNULL),COLOR0000FF,DOTLINE;
上3:IF(上斜线3&lt;=天线*1.05,上斜线3,DRAWNULL),COLORAA00AA,DOTLINE;
上2:IF(上斜线2&lt;=天线*1.05,上斜线2,DRAWNULL),COLORAA00AA,DOTLINE;
上1:IF(上斜线1&lt;=天线*1.05,上斜线1,DRAWNULL),COLORAA00AA,DOTLINE;
上0:IF(上斜线0&lt;=天线*1.05,上斜线0,DRAWNULL),COLORAA00AA,DOTLINE;
上:IF(上斜线&lt;=天线*1.05,上斜线,DRAWNULL),COLORAA00AA,DOTLINE;
下斜线:=IF(天线-CONST(H斜率*4.00)*最高&lt;=天线,天线-CONST(H斜率*4.00)*最高,DRAWNULL);
下斜线0:=IF(天线-CONST(H斜率*2.00)*最高&lt;=天线,天线-CONST(H斜率*2.00)*最高,DRAWNULL);
下斜线1:=IF(天线-CONST(H斜率*1.500)*最高&lt;=天线,天线-CONST(H斜率*1.500)*最高,DRAWNULL);
下斜线2:=IF(天线-CONST(H斜率*1.000)*最高&lt;=天线,天线-CONST(H斜率*1.000)*最高,DRAWNULL);
下斜线3:=IF(天线-CONST(H斜率*0.70)*最高&lt;=天线,天线-CONST(H斜率*0.70)*最高,DRAWNULL);
下斜线4:=IF(天线-CONST(H斜率*0.50)*最高&lt;=天线,天线-CONST(H斜率*0.50)*最高,DRAWNULL);
下斜线5:=IF(天线-CONST(H斜率*0.365)*最高&lt;=天线,天线-CONST(H斜率*0.365)*最高,DRAWNULL);
下斜线6:=IF(天线-CONST(H斜率*0.250)*最高&lt;=天线,天线-CONST(H斜率*0.250)*最高,DRAWNULL);
下斜线7:=IF(天线-CONST(H斜率*0.165)*最高&lt;=天线,天线-CONST(H斜率*0.165)*最高,DRAWNULL);
下斜线8:=IF(天线-CONST(H斜率*0.123)*最高&lt;=天线,天线-CONST(H斜率*0.123)*最高,DRAWNULL);
下斜线9:=IF(天线-CONST(H斜率*0.06)*最高&lt;=天线,天线-CONST(H斜率*0.06)*最高,DRAWNULL);
下9:IF(下斜线9&gt;=地线*0.95,下斜线9,DRAWNULL),COLORAAAAAA,DOTLINE;
下8:IF(下斜线8&gt;=地线*0.95,下斜线8,DRAWNULL),COLORAAAAAA,DOTLINE;
下7:IF(下斜线7&gt;=地线*0.95,下斜线7,DRAWNULL),COLORAAAAAA,DOTLINE;
下6:IF(下斜线6&gt;=地线*0.95,下斜线6,DRAWNULL),COLORAAAAAA,DOTLINE;
下5:IF(下斜线5&gt;=地线*0.95,下斜线5,DRAWNULL),COLORAAAAAA,DOTLINE;
下4:IF(下斜线4&gt;=地线*0.95,下斜线4,DRAWNULL),COLOR0000FF,DOTLINE;
下3:IF(下斜线3&gt;=地线*0.95,下斜线3,DRAWNULL),COLORAAAAAA,DOTLINE;
下2:IF(下斜线2&gt;=地线*0.95,下斜线2,DRAWNULL),COLORAAAAAA,DOTLINE;
下1:IF(下斜线1&gt;=地线*0.95,下斜线1,DRAWNULL),COLORAAAAAA,DOTLINE;
下0:IF(下斜线0&gt;=地线*0.95,下斜线0,DRAWNULL),COLORAAAAAA,DOTLINE;
下:IF(下斜线&gt;=地线*0.95,下斜线,DRAWNULL),COLORAAAAAA,DOTLINE;
{黄金分割}
X146:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.146,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X146)*1.001,STRCAT(' 0.146%% ',CON2STR(X146,3))),COLOR889900;
X191:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.191,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X191)*1.001,STRCAT(' 0.191%% ',CON2STR(X191,3))),COLOR889900;
X236:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.236,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X236)*1.001,STRCAT(' 0.236%% ',CON2STR(X236,3))),COLOR889900;
X382:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.382,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X382)*1.001,STRCAT(' 0.382%% ',CON2STR(X382,3))),COLOR889900;
X500:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.500,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X500)*1.001,STRCAT(' 0.500%% ',CON2STR(X500,3))),COLOR889900;
X618:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.618,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X618)*1.001,STRCAT(' 0.618%% ',CON2STR(X618,3))),COLOR889900;
X764:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.764,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X764)*1.001,STRCAT(' 0.764%% ',CON2STR(X764,3))),COLOR889900;
X809:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.809,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X809)*1.001,STRCAT(' 0.809%% ',CON2STR(X809,3))),COLOR889900;
X854:IF(CURR&lt;=GTHT,SX跌H-(SX跌H-SX涨L)*0.854,DRAWNULL),DOTLINE,COLOR556600;
DRAWTEXT(CURR=GTHT,(X854)*1.001,STRCAT(' 0.854%% ',CON2STR(X854,3))),COLOR889900;
{斐波那契周期}
DRAWTEXT(CURRBARSCOUNT=GTT,SX跌H*1.02,'斐波那契下跌周期'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GTT,SX跌H*1.01,'1'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-2,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-2,SX跌H*1.01,'3'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-4,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-4,SX跌H*1.01,'5'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-7,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-7,SX跌H*1.01,'8'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-12,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-12,SX跌H*1.01,'13'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-20,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-20,SX跌H*1.01,'21'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-33,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-33,SX跌H*1.01,'34 '),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-54,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-54,SX跌H*1.01,'55'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-67,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-67,SX跌H*1.01,'68'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-88,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-88,SX跌H*1.01,'89'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-109,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-109,SX跌H*1.01,'110'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-143,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-143,SX跌H*1.01,'144'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=DTT,SX涨L*0.96,'斐波那契上升周期'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=DTT,SX涨L*0.98,'1'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-2,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-2,SX涨L*0.98,'3'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-4,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-4,SX涨L*0.98,'5'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-7,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-7,SX涨L*0.98,'8'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-12,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-12,SX涨L*0.98,'13'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-20,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-20,SX涨L*0.98.01,'21'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-33,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-33,SX涨L*0.98,'34'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-54,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-54,SX涨L*0.98,'55'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-67,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-67,SX涨L*0.98,'68'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-88,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-88,SX涨L*0.98,'89'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-109,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-109,SX涨L*0.98,'110'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-143,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-143,SX涨L*0.98,'144'),COLOR0000FF;
A1:=C&gt;REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11&gt;0,9) OR BACKSET(TJ13&gt;0,NT))*NT;
DRAWTEXT(AY&gt;0,H*1.01,VAR2STR(AY,0)),COLORFF00FF;
DRAWTEXT(NT=9,H*1.01,'9'),COLORGREEN;
B1:=C&lt;REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21&gt;0,9) OR BACKSET(TJ23&gt;0,NT0))*NT0;
DRAWTEXT(AY1&gt;0,L*0.99,VAR2STR(AY1,0)),COLORGREEN;
DRAWTEXT(NT0=9,L*0.99,'9'),COLORGREEN;


                       
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 马上注册

本版积分规则