赞助商广告,谨慎操作

通达信波段乾坤图指标公式

[复制链接]
查看14 | 回复0 | 2020-11-20 10:00:29 | 显示全部楼层 |阅读模式
公众号
http://www.gaoshouluntan.com/202011/53633.html
http://www.gaoshouluntan.com/202011/53634.html
http://www.gaoshouluntan.com/202011/53635.html
</div>
A1:=DATE &lt;= 1070615;
A2:=(100 * (CLOSE - (MA(CLOSE,30)))) / (MA(CLOSE,30));
A3:=100 - ((90 * ((HHV(HIGH,20)) - CLOSE)) / ((HHV(HIGH,20)) - (LLV(LOW,20))));
A4:=100 - (MA(((100 * ((HHV(HIGH,6)) - CLOSE)) / ((HHV(HIGH,6)) - (LLV(LOW,6)))),28));
A5:=MA(A4,6);
A6:=(3 * (SMA((((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100),5,1))) - (2 * (SMA((SMA((((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100),5,1)),3,1)));
A7:=(10);
百万测底(CROSS(A6,A7)) * 75) * A1,LINETHICK2,COLOR0000FF;
A8:=(REF(CLOSE,1)) / CLOSE;
A9:=MIN((MA(((AMOUNT / VOL) / 100),15)),(EMA(((AMOUNT / VOL) / 100),15)));
A10:=((1 - ((SMA(((LOW * A8) - (A8 / 10)),6,1)) / (EMA(((AMOUNT / VOL) / 100),15)))) * 100) - (100 / 10);
A11:=((((1 - ((MA((LOW - (A8 / 10)),6)) / A9)) * (DMA(CLOSE,(VOL / CAPITAL)))) / (MA(LOW,6))) * 100) - (100 / 10);
A12:=((((A10 + (A11 / 10)) &gt; 0) AND (DATE &gt; 1000101)) AND (DATE &lt; 1991231)) AND ((COUNT((((1 - (CLOSE / (REF(CLOSE,1)))) &gt; 0.099) AND ((1 - ((REF(CLOSE,1)) / (REF(CLOSE,2)))) &gt; 0.099)),20)) &lt; 3);
A13:=(((((((A10 + (A11 / 10)) &gt; -3.688) AND (DATE &gt; 1000101)) AND (DATE &lt; 1991231)) AND ((CLOSE / (REF(CLOSE,1))) &gt; 1.02)) AND ((COUNT((((1 - (CLOSE / (REF(CLOSE,1)))) &gt; 0.099) AND ((1 - ((REF(CLOSE,1)) / (REF(CLOSE,2)))) &gt; 0.099)),20)) &lt; 3)) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) &lt; 0.95)) AND ((CLOSE / (HHV(HIGH,20))) &lt; 0.855);
灵桥黑马(IF(((((100 &lt; 100) AND ((A10 + (A11 / 10)) &gt; 0)) AND (DATE &gt; 1000101)) AND (DATE &lt; 1991231)),(A12 = 1),(A13 = 1))) * 100) * A1,LINETHICK2,COLORRED;
A14:=EMA(CLOSE,8);
A15:=EMA(A14,20);
A16:=CROSS(A14,A15);
A17:=A14 &lt; (EMA(CLOSE,120));
大波黑马起步(A16 AND A17) * 75) * A1,LINETHICK2,COLORYELLOW;
A18:=SUM((IF((CLOSE &gt; (REF(CLOSE,1))),VOL,(IF((CLOSE &lt; (REF(CLOSE,1))),(0 - VOL),0)))),0);
A19:=SUMBARS(VOL,CAPITAL);
A20:=(IF((CLOSE &gt; (LLV(CLOSE,A19))),1,-1)) * (IF((A18 &gt; (LLV(A18,A19))),1,-1));
A21:=IF((A20 = -1),1,0);
A22:=(COUNT((A21 = 1),8)) &gt; 2;
A23:=((SUM(AMOUNT,13)) / ((AMOUNT / VOL) / 100)) / 100;
A24:=DMA((((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7),(VOL / A23));
A25:=(((CLOSE - A24) / A24) * 100) &lt; -15;
A26:=((CLOSE - (MIN(((REF(CLOSE,5)) * 0.865),((REF(CLOSE,21)) * 0.772)))) / CLOSE) &lt; 0.05;
A27:=REF(LOW,1);
A28:=((SMA(ABS((LOW - A27)),3,1)) / (SMA((MAX((LOW - A27),0)),3,1))) * 100;
A29:=EMA((IF((CLOSE * 1.2),(A28 * 10),(A28 / 10))),3);
A30:=LLV(LOW,38);
A31:=HHV(A29,38);
A32:=IF((LLV(LOW,90)),1,0);
A33:=((EMA((IF((LOW &lt;= A30),((A29 + (A31 * 2)) / 2),0)),3)) / 618) * A32;
(STICKLINE(A33,0,A33,6,1));
底部不买你后悔IF(((A25 AND A26) AND A22),60,0)) * A1;
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
短线:SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00;
中线:SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED;
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
长线:SMA(RSV3,5,1),COLORYELLOW;
看底:STICKLINE(中线&lt;15,中线,15,6,0),COLORF00FF0;
黄金坑:STICKLINE(短线&lt;20 AND 中线&lt;20 AND 长线&lt;20,MAX(长线,MAX(短线,中线)),20,8,0),COLOR00CCFF;
看顶:STICKLINE(中线&gt;80,80,中线,6,0),COLORFFF000;
DRAWICON(CROSS(长线,15),中线,1);
DRAWTEXT(LONGCROSS(中线,20,15),20,'追涨');
DRAWTEXT(CROSS(短线,长线)AND 长线&lt;18 AND 长线&gt;REF(长线,1)OR CROSS(长线,5),20,'千载难逢');
粘合星RAWTEXT(ABS(中线-长线)&lt;2 AND 中线&gt;REF(中线,1),中线,'*');
中线2:=-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40));
RAWTEXT(CROSS(中线2,-90) AND (长线&lt;中线 AND 长线&gt;REF(长线,1)OR 短线&lt;20 AND 中线&lt;20 AND 长线&lt;20),长线,'底'),COLORFF00FF;
IF(COUNT(CROSS(中线2,-90),12)=3,30,5);
IF(COUNT(CROSS(-5,中线2),12)=3 OR COUNT(CROSS(-15,中线2),6)=3,70,100);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD &gt; 0) AND (HD &gt; LD)),HD,0),10);
DMM:=SUM(IF(((LD &gt; 0) AND (LD &gt; HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
0,COLORFF00FF;
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
STICKLINE((阶段底部 &lt; 0),0,-10,0.8,1),LINETHICK6,COLORYELLOW;
趋势线:=LLV(阶段底部,1),COLORWHITE,LINETHICK0;
STICKLINE(CROSS(阶段底部,0),0,-10,0.8,1),LINETHICK6,COLORRED;
STICKLINE((趋势线 &gt;230 ),100,90,0.3,1),LINETHICK6,COLORGREEN;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:EMA(RSV,3),CIRCLEDOT;
D:MA(K,3),CIRCLEDOT;
STICKLINE(K&gt;D , K,D ,2.5,0),COLORRED,LINETHICK2;
STICKLINE(D&gt;K,K,D,2.5,0),COLORGREEN,LINETHICK2;
逃顶线:90,COLORGREEN;
中轴线: 50,COLORRED;
抄底线:10,COLORGREEN;
DRAWICON(CROSS(K,D),12,1)COLORRED;
DRAWICON(CROSS(D,K),88,2)COLORGREEN;


                       
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 马上注册

本版积分规则